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Пројектовање технолошког процеса (Manufacturing Model) 
израде коришћењем модула Pro|NC програмског пакета 
Pro|ENGINEER 
 
Сврха вежбања:  Упознавање са начином рада софтверских алата за пројектовање и 

моделирање технолошког процеса. Овладавање основним техникама рада у 
програму Pro|ENGINEER. 

 
Садржај:  Избор површине на коју се алат враћа између захвата (Retract Surface) 

(Pro|NC), 
 Пројектовање или дефинисање захвата (NC Sequence) 
 бушење, спољашње уздужно стругање, унутрашња обрада, чеона обрада, 

израда радијалног жљеба, израда навоја, стварање излазних датотека 
   Дефинисање технолошких параметара, 
   Дефинисање геометрије обраде, 
   Симулација кретања алата у стругарској обради 

1. Избор површине на коју се алат враћа између захвата (Retract 
Surface) и тачке са које алат креће у захват и у коју се враћа 
након обраде 

 
 

У наставку рада са CAM модулом, 
потребно је изабрати и површине на коју 
се алат враћа између захвата (Retract 
Surface). У овом случају, то ће бити 
цилиндрична површина чија ће се оса 
поклапати са z-осом Mfg модела, а 
вредност полупречника цилиндра се 
дефинише од стране корисника (нешто 
већи од полупречника припремка). 

 

Следећи корак је да се дефинише тзв. From и Home тачка, позиција 
са које алат креће у захват и у коју се враћа након обраде. За то је 
потребно имати већ креирану Datum тачку негде у простору (онамо 
где то заиста јесте лоцирано на машини). У овом примеру, на овом 
кораку, покреће се процедура израде Datum тачке на основу опције 
дефинисања Datum тачке помоћу координатног система – односно 
њеног удаљења од коор. почетка  

У процедури дефинисања 
тачке пре свега треба изабрати 
координатни почетак обрадка 
(Deo) или припремка, а потом 
треба унети за  
X=150mm 
Z=150mm, ... OK 
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2. Пројектовање или дефинисање захвата (NC Sequence) 
 
Ако се изузме да је могуће дефинисати и 
параметри који дефинишу тзв. Output 
(како ће изгледати излазни документ 
/APT), може се рећи да је комплета сет 
параметара који дефинишу „операцију“ 
одређен.  

 Следећи корак јесте да се крене у 
дефинисање захвата, односно 
њихових параметара. 

Дефинисање захвата (NC Sequence-а) се 
изводи избором опције Machining са 
падајућих менија  

Следи избор типа захвата. Ми у овом  
случају бирамо тип захвата за израду 
отвора и рупа Holemaking (→ Done); и 
подопције 

Drill → Standard → Done 

Отвара се нови скуп подменија у којима 
се даље дефинишу сви остали параметри 
који су релевантни овом типу захвата ...    
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  Мени SEQ SETUP нам пружа могућност да изаберемо које 

параметре желимо да експлицитно утврдимо, а које желимо да 
препустимо да сам Pro/NC дефинише према неком 
иницијалном сету вредности. 

 У овом случају изаберите опције на слици и у првом 
кораку унесите назив захвата 

  
На следећем кораку 
потребно је да 
изаберете алат са 
којим ћете обављати 
обраду у овом 
захвату. 

Како је приликом 
избора машине 
учитан и скуп алата 
који је «смештен» у 
магацин алата, то су 
и подаци који 
одговарају овим 
алатима, а вези са 
геометријом и 
применом, постали 
доступни за преглед 
и измену. 

У примеру, се бира 
бургија са ознаком 

IDTSS087 

2.1 Дефинисање технолошких параметара 
Када је алат изабран, следи корак дефиниције параметара који се тичу 
технолошких особености захвата (корак, брзина резања, тип или класа путање 
алата, улазно-излазни елементи путање, и др.) 

MFG PARAMS → Set  

Треба уочити да у дијалог-
маски која се приказује током 
дефинисања параметара 
постоји и командно дугме 
којим се бира да ли се жели 
контролисати комплетан сет 
параметара (Advanced) или 
само тзв. основни скуп 
(Simplified). 

Напомена: 
Оно што је битно јесте да 
само комплетан скуп 
параметара омогућава 
потпуну контролу свих 
параметара захвата! 
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Избор површине на коју се алат враћа 
Како је приликом избора опција које се желе непосредно контролисати , 
изабрана и опција за дефиницију тзв. Retract равни 

 (У случају овог захвата – бушења, раније дефинисани цилиндар 
нема много смисла, јер је овде површина на коју се алат враћа 
након обраде заправо раван која је нормална на z-осу!) 

Retract → Specify → Make Datum   

 

 

Из тог разлога, на овом кораку се 
захтева да се «у лету» дефинише, 
тј. креира Datum раван која ће 
послужити као Retract раван! 

 У овом примеру за креирање 
Datum равни, коришћена је 
опција Offset (паралаленог 
копирања од познатог геом. 
ентитета: искоришћена је 
чеона површина припремка) 

Offset → Plane → Facet face → 
Enter Value 

Вредност паралелног померања 
треба унети (3мм) 

2.2 Дефинисање геометрије обраде (захват: Бушење) 

Коначно, следи корак утврђивања 
параметара геометрије која треба да 
се обради, тзв. технолошких 
површина и у опште технолошких 
типских елемената (Manufacturing 
geometry)! 

Како је већ раније декларисан тип 
захвата: Бушење – ProNC нуди 
одговарајући дијалог-образац 
HoleSet у коме треба изабрати 
одговарајуће опције и дефинисати 
адекватне вредности. 

 Да би се описала геометрија која 
се жели обрађивати (отвор) у 
овом случају ће се искористити 
оса израдка или припремка – 
треба изабрати „картицу“ Axes, а 
затим и изабрати осу са модела и 
коначно активирати изабрану осу 
притиском на командно дугме 
Add 
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 Утврђивање дубине 
бушења започиње 
притиском на 
командно дугме 
Depth… 

Потом треба изабрати 
опцију Auto којом се 
оставља ProNC-у да сам 
одреди ову вредност на 
основу избора дела из Mfg 
модела.  

Следи избор израдка.  
Напомена: Како је 
припремак у виртуелном 
простору „испред“ 
израдка треба се 
послужити техником 
избора ентитета са 
модела помоћу десног 
тастера на мишу! 

2.3 Симулација кретања алата 
Сада су сви параметри захвата дефинисани и оно што треба да следи 
јесте симулација како би се установило да ли је пројектовани захват 
заправо оно што смо желели. Ако није, или ако има неких недостатака, 
могуће је вратити се у процедуру пројектовања (избором опције Seq 
Setup). 

Симулација се може изводити на три начина: 

Први: који се покреће опцијом Play Path → Screen Play омогућава 
измене покрета и најситнијих детаља путање алата унутар захвата и 
додавања постпроцесорских директива (нпр. накнадног чекања алата на 
некој позицији и др.)!, 

Други: Play Path → NC Check даје симулацију са рендерованим 
облицима како припремка, тако и алата и принципијелно је намењена пре 
свега бољој визуелизацији. 

Трећи: Play Path → Gouge Check опција служи да би се њоме посебно 
разматрала могућа интерференција (недозвољена задирања) алата и 
припремка и алат и стезног прибора! 

 

 

 

Опцијом Play Path → 
Screen Play могуће је 
„ући“ у детаљан увид у APT 
код (CL Data) и прегледати 
га. Такође, дијалог-образац 
Customize допушта да се 
накнадно мења претходно 
аутоматски дефинисана 
путања алата 
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Ако смо зтадовољни са пројектованим захватом, потребно је да се 
потврди дефинсани скуп података и тако стаблу mfg модела додели нови 
– технолошки feature избором опције 
Done Seq 

 

 

 

 
 Понеки од захвата, у зависности који је тип, 
тј. како је настао и пројектован, омогућава да 
се аутоматски креира тзв. Material Remove 

feature – Matrl Remove опција. Овај CAD 
feature је заправо геометријска форма која 

одговоара CUT  featrue-у, а настаје као 
последица уклањања материјала након 
технолошког feature-а, тј. захвата (NC 

Sequence). 

Опција Matrl Remove отвара нови подмени 
NC SEQ LIST у коме је приказана листа 
претходно креираних захвата. Избором 

одређеног захвата отвара се могућност да се 
креира овај тип feature-а било аутоматски, било да се самостално креира 

одговарајући Cut feature (опција Construct). 

 У случају овог захвата, бушења, могуће је искористити опцију за аутоматско 
„уклањање материјала захватом“ - Automatic.   

Matrl Remove → Automatic 

2.4 Дефинисање захвата спољашњег уздужног стругања 
Започињање новог захвата покреће се 
избором опције: New Sequence, 
а потом настављамо са бирањем типа 
захвата. 

У овом случају, следећи захват је грубо 
уздужно стругање. Овај тип захвата могуће је 
креирати избором једном од следећих опција 
Machining → Area , или  
Machining → Profile 

 Конкретно, требате да изаберете опцију 
Machining → Area  

 На следећем кораку процедуре, као и код 
бушења, бирају се опције за непосредно 
подешавање параметара захвата  

Конкретно, 
требате да 
изаберете опције 

Name 

Start 

End 
 
На захтев за унос 
назива захвата 
унесите 
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 Следи избор алата (T3) 

 

Приликом дефинисања технолошких параметара MFG 
PARAMS овог пута користиће се раније припремљени сет 
параметара који је смештен у датотеци (документу) у 
директоријуму mfgparam: spoljasnje_struganje.trn  

У наредним корацима врши се дефиниција геометрије путање 
алата 
 
У првом наредном кораку треба селектовати „стартну“ и „крајњу“ 
позиције алата у захвату који се дефинише. Могуће је изабрати 
From_Home Datum тачку у оба случаја. 

 

Следи корак дефинисања 
технолошке геометрије, тј. 
у овом конкретном случају 
дефинисање профила 
(контуре) који се треба 
добити након захвата! 

Порцедура започиње  
притиском на командно 
дугме Insert на дијалог-
обрасцу Customize, а потом 
избором опције 

Create Profile → Section 
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Pro/NC ће препознати  
уздужни пресек дела и 
представити га низом 
елементарних 
геометријских ентитета 
(линија и лукова). 

Потребно је 
селектовати две тачке 
на уздужном пресеку, 
почетну и крајњу тачку  
профила који ће бити 
коришћен за 
дефинисање обрадног 
профила – у овом 
случају за спољашњу 
обраду. 

 

 

Следи избор стране на којој ће обрада бити вршена - Pro/NC ће 
индиковати стрлицом могуће стране обраде: 

 Са горње (спољашње) стране профила (контуре) – Above CtrLn, што 
ће бити у овом конкретном случају избор, 

 Са доње стране профила (контуре) – Below CtrLn  
 
На крају следи потврда избора → Done 

 

  
 

 
 

У наредном кораку 
процедуре дефинисања 
профила или контуре 
обраде, треба селектовати 
једну од две контуре које 
су настале избором 
почетне ии крајње тачке. 

 Toggle Profile 

 Done/Return 
 

 



Пројектовање производње помоћу рачунара   Вежбе – Pro|ENGINEER  (верз. Wildfire) 

  
 - Страна 9 - 

 
Поједини делови изабраног профила (контуре) 
неће моћи да буду израђени изабраном резном 
геометријом (алатом). Из тог разлога, потребно је 
додатно изменити или подесити већ изабрани 
профил. У конкретном случају потребно је 
уклонити делове контуре који представљају 
радијални жљеб и поравнати тај део контуре. 

То се изводи избором опције 

Adjust Turn Profile 
са дијалог-обрасца CURVE: Turn Profile, 

a потом притиском на командно дугме Define 
отвара се нови дијалог Adjust Profile.  

На овом дијалогу процедура измене профила 
започиње притиском на ком. дугме са симболом 
стрелице:  и избором опције  

Adjustment Options → Line Connect 

Следи избор крајњих тачака оних геом. ентитета 
који се желе „спојити“.  

Притиском на ком. Дугме Add овај спој постаје 
део профила и притиском на OK на дијалог-
обрасцу потврђује се коначан избор профила. 

 

 

 
 

 
 
 

Коначно, на стаблу Mfg модела настаје нови feature -  
профил струграске обраде,  

 

У задњем кораку дефиниције путање алата потребно 
је дефинисати правце излаза алата (EXT DIR): 
 
Extensions → Positive X (за правац излаза алата када 
се након сваког пролаза нађе на тзв. крајњој тачки 
профила), и  
 
Extensions → Positive Z (за правац „улаза“ алата када 
се након сваког пролаза нађе на тзв. почетној тачки 
профила) 
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2.5 Симулација кретања алата у стругарској обради 
 

 
 

Остаје да се симулацијом резања провери да ли 
је креирана путања алата одговарајућа избором 
опције  
Play Cut  
На овом кораку могуће је подешавати приказ 
симулације, нпр. у погледу брзине приказивања 
избором опције  
Time Increment → Enter, 
а потом на захтев Pro/NC-а унети вредност 0.05 
 
Ако смо задовољни, избором опције 
Done 
завршавамо порцедуру дефиниције захвата 
спољашњег уздужног стругања! 

Симулацију је могуће спровести и помоћу опције 
NC Check → Display → Run  
Додатне опције које помажу да се повећа квалитет 
визуелизације јесу Resolution (1 x 1) и Step Size → Enter 
(унети, у овом случају, број 2 када систем захтева унос) 
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3. Наставак пројектовања захвата (NC Sequence) 
 
Овог пута треба израдити утрушање стругање. Поступак је исти 
као и код спољашњег стругања, с тим што се једино мења 
оријентација алата (у табели параметара захвата) 

Остале кораке треба поновити као и код спољашњег стругања, 
наравно, изменити назив, алат, изабрати стартну и крајњу тачку 
алата у захвату 

  

 

 

 
 Ове вредности алата: Side Width и  Tool Width 
су посебно значајне код унутрашњег стругања! 

 Могу се заменити вредности за ширину и 
Dmax и B и H држача. 
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 Када се нађемо на кораку за дефиницију 
параметара можете да учитате раније 
припремљени сет параметара 

  

 Ипак овог пута потребно је д аизвршите по 
неке измене 

 Ипак опцију из сета опција CUT OPTION 
ROUGH_&_CLEAN_UP у ROUGH_&_PROF. То 
је начин да се након грубе обраде изврши и 
тзв. профилисање! 

 При томе, треба уједно променити и низ 
других параметра (види слике) 

 Посебно је битно нагласити да је измењен 
параметар оријентације алата у захвату са 90º 
на 
0º 

 

 

 

 На крају овог корака измените и параметре 
који се тичу улазно-излазних кретања алата у 
захвату! 
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 Следи корак дефиниције профила или 
контуре по којој ће се вршити обрада. 

 Као и у примеру са спољашњим 
стругањем, и овде ће бити потребно 
извршити по неку измену на 
аутоматски створеној контури – треба 
„премостити“ унутрашњи радијални 
жљеб.  

 Процедура је иста као и у случају 
захвата спољашњег стругања. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 Када се заврши са контуром, 
следи додела праваца уласка  и 
и изласка у захват (резање), 
тзв. Extensions. 
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 Остаје да се 
провери да ли 
је путања 
лата у захвату 
онаква каква 
је 
намеравана. 

 

 

 

 
 

 
 

 Као и у случају раније дефинисаних захвата, и 
овде ћемо креирати feature тзв. уклањања 
материјала Matrl Remove. 

 

4. Захват чеоног стругања 
 

  Захват чеоног (или 
попречног) стругања се 
пројектује на истоветни 
начин као и захвати 
уздужне обраде. 
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 Избор алата мопже да буде исти као и ко 
уздужног стругања – алат са “C” плочицом 
нападног угла: κ=95º и κ1=5º, може да се 
употреби за управни правац обраде. 

 Касније се такође може изабрати иста Start и 
End тачка путање алата у захвату. 

 
 

 

 Избор параметара обраде такође је могуће 
учитати из раније припремљене датотетке 
„ceono_struganje.trn” 

 Посебно треба обратити пажњу да подешавање 
угла резања – којим дефинишемо правац 
кретања алата (CUT_ANGLE = 0º /уздужна 
обрада, CUT_ANGLE = 90º /попречна обрада)  
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 Следи дефинисање профила, који је у овом 
случају далеко једноставнији него у 
претходна два случаја. 

 

 

 Ипак, и овде треба извршити извесна „фина“ 
подешавања – треба продужити путању, тј. 
контуру на крајевима како би алат „скинуо“ у 
потпуности материјал који је заостао од 
уздужне обраде по спољашњој контури 
обзиром да је било извесне количине 
материјала од додатака за фину обраду. 

 Треба изабрати опцију Ends → Start → 
Specify → ExtLength и уписати 3mm. 

 

 

 

 

 

 

 

 Следи симулација зхвата и уклањање 
материјала 
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5. Захват усецања радијалног жљеба 
 Захват усецања 
радијалног жљеба се 
пројектује на истоветни 
начин као и захвати 
уздужне и попречне 
обраде с тим што се бира 
опција Groove 

 Код избора алата треба 
обратити пажњу (у овом 
случају је то алат у 
магацину на 5. месту - T5) 

 Дакле, тип алата је 
другачији TURN-
GROOVING, и свакако 
геометрија. 

 

 
 Код пројектовања профила поштује се исти 
поступак као у претходна три случаја. 

 Разлика је у томе што су Extensions захвата 
нешто другачији ... 

 Обратити пажњу приликом подешавања 
параметара.DELAY 

 

 

 

 

 Након симулације треба још и уклонити 
материјал 
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6. Захват израде спољашњег навоја 
 

 Захват усецања радијалног жљеба се 
пројектује на истоветни начин као и захвати 

уздужне и попречне 
обраде с тим што се 
бира опција Groove 

 

 У следећем кораку треба дефинисати 
параметаре обраде – у овом случају ради се о 
M70x4!  

 Потребно је предвидети 8 пролаза алата 
подешавање угла резања, сетовати  број 
обртаја, корак и др. 

 Код избора алата потребно је селектовати алат 
T7, али потом треба још изменити и параметре 
геометрије алата - 
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  Након симулације није могуће 
искористи feature аутоматског 
генерисања уклањања 
материјала, осим ако се 
самостално не креира CUT 
feature. 

 

 Остале захвате – израда унутрашњег 
радијалног жљеба, као и унутрашњег навоја 
и одсецања – треба урадити самостално! 
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7. Стварање излазних датотека (CL Data file /*.ncl/, G-код /*.tap/) 
 

 Стварање излазних датотека, тј. CL Data file /*.ncl/, G-код /*.tap/ започиње 
се тако што се креира CL Data датотека читаве операције CL Data → Output 
→ Select One → Operation 

 Сада треба изабрати једину до сада пројектовану операцију: STRUGANJE 
 

Опција File омогућава да се пројектована операција „извезе“ у 
тзв. APT формат (опција CL File) и G-код  (опција MCD File). 
Након потврде избором опције Done отвара се дијалог прозор 

у коме је потребно декларисати назив новог 
ncl и tap записа (датотеке) – нпр. struganje 
 
Опција MCD нас даље води у процедуру 

пост-процесирања 
PP OPTIONS 
 
Verobose опција која 
служи за праћење 
активности пост-
процесирања 
 
Trase опција за праћење 
свих макроа који прате 
процес пост-процесирања 
 

 

 

 

 

 

 Сада треба изабрати 
један од тзв. генеричких 
пост-процесора. Сви 
постпроцесори који 
завршавају са X  
(UNCX01.Pxx) су 
намењени за обраду на 
глодалици, WEDM-у, 
ласеру или Waterjet-у 
док су они који се 
завршавају на L 
(UNCL01.Pxx) генерички 
постпроцесори за 
обраду на стругу. 

 Они се називају 
генеричким, зато што 
могу бити искоришћени 
као узорни примерак 
посебног пост-

процесора који ће бити намењен посебној УЈ 
НУМА. Подешавање пост-процесора, односно 
измена сета инструкција,  могуће је изводити у 
посебној програмској апликацији. 
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 У овом конкретном 
случају могуће изабрати 
нпр. UNCL01.P13 
генерички постпроцесори 
за обраду на стругу. 

 Ова активност ће 
генерисати тзв. G-код 
датотеку са екстензијом 
tap  

 
 

 

 Касније, када се жели симулирати не само 
APT код, тј. за симулацију користи CL Data 
file /*.ncl/, већ и сами G-код, потребно је 
изабрати опције 

NC Check → G-Code File (Interactive) → 
Done 

Да би ова врста симулације – дакле 
симулација G- кода обавила потребно је 
користити окружење Vericut апликације.  

Објашњења која се тичу подешавања и 
коришћења Vericut апликације превазилазе 
планирани ниво овог курса. 
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8. Излазак из програма 

 

 

 Правилан начин изласка из програма (Pro|E и 
Pro|NC модула се изводи тако што се: 

1. Сачува претходни рад (ако је то потребно) 
2. Избрише из радне меморије рачунара и 

програма сви (Select All – види доњу леву 
слику) активни модели и модели који се налазе 
у „позадини”, командом Erase! 

3. И тек сада, File → Exit. 
 
Напомена: ако се жели почистити радни директоријум 
од старијих верзија модела (посебно битно код рада са 
Pro|NC модулом јер тада свака акција Save врши трајно 
чување актуелне верзије модела), препорука је да се 
корсити акција File → Delete → Old Versions. 
 

 

 

 

 


